We’re doing some maintenance
Incident Report for Zilch Production
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 05:55 UTC
Update
We are continuing to investigate this issue.
Posted Nov 14, 2024 - 05:53 UTC
Update
Sorry, you can’t make any purchases right now but we’ll be back shortly.
Posted Nov 14, 2024 - 05:17 UTC
Update
We are continuing to investigate this issue.
Posted Nov 14, 2024 - 05:16 UTC
Investigating
Sorry, you can’t make any purchases right now but we’ll be back shortly.
Posted Nov 14, 2024 - 05:16 UTC
This incident affected: Website (UK) (Core) and Mobile app (UK) (Core).